summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/control17
-rwxr-xr-xdebian/rules22
-rw-r--r--debian/source/format1
4 files changed, 45 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..69b8713
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+bandwhich (0.9.0) bionic; urgency=medium
+
+ * Initial debian packaging
+
+ -- Michael Aaron Murphy <michael@system76.com> Thu, 16 Jan 2020 8:26:58 -0700
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..7c04b07
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,17 @@
+Source: bandwhich
+Section: utils
+Priority: optional
+Maintainer: Michael Aaron Murphy <mmstick@pm.me>
+Build-Depends:
+ cargo (>=0.40),
+ clang,
+ debhelper-compat (=9),
+ rustc (>=1.39)
+Standards-Version: 4.4.1
+Homepage: https://github.com/imsnif/bandwhich
+
+Package: bandwhich
+Architecture: any
+Depends: ${misc:Depends}, ${shlib:Depends}
+Description: Terminal bandwidth utilization tool
+ Terminal bandwidth utilization tool
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d16f6b9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+export VENDOR ?= 1
+export prefix = /usr
+CLEAN ?= 1
+
+%:
+ dh $@
+
+override_dh_auto_clean:
+ifeq ($(CLEAN),1)
+ make clean;
+endif
+ifeq ($(VENDOR),1)
+ if ! ischroot; then \
+ make vendor; \
+ rm -rf vendor; \
+ fi
+endif
+
+override_dh_auto_build:
+ env CARGO_HOME="$$(pwd)/target/cargo" dh_auto_build
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)