summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 11559a3..b635457 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,6 +34,10 @@ trust-dns-resolver = "0.18.1"
async-trait = "0.1.21"
unicode-width = "0.1.8"
+[target.'cfg(target_os="windows")'.dependencies]
+netstat2 = "0.9.0"
+sysinfo = "0.15.1"
+
[target.'cfg(target_os="linux")'.dependencies]
procfs = "0.7.4"
@@ -43,3 +47,8 @@ pnet_base = "0.26.0"
cargo-insta = "0.11.0"
packet-builder = "0.5.0"
regex = "1"
+
+[build-dependencies]
+#[target.'cfg(target_os="windows")'.build-dependencies]
+http_req = "0.7.0"
+zip = "0.5.6"