summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authoretoledom <etoledom@icloud.com>2019-11-12 11:46:35 +0100
committerAram Drevekenin <aram@poor.dev>2019-11-12 11:46:35 +0100
commit68b7a0e7d5ed4ca09d2f694d989b6423da1b4afd (patch)
treec49bc46e4fe1469c1d148f7e7bb32171fcad502b /Cargo.toml
parentcab84a0015bd5cd3d817a13dceaca5ebbdf23208 (diff)
feat(platform): support macos (#8)
* Running on MacOS * Working on MacOs 🎉 * [MacOS] Adding process name * Fix cargo procfs dependency for MacOS * [MacOS] Fix syntax error. * Fix cargo procfs dependency for Linux. The real one! * Fix build warnings
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7afc6ba..72b1230 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,8 +22,9 @@ dns-lookup = "1.0.1"
signal-hook = "0.1.10"
failure = "0.1.6"
chrono = "0.4"
+regex = "*"
-[target.'cfg(unix)'.dependencies]
+[target.'cfg(target_os="linux")'.dependencies]
procfs = "0.5.3"
[dev-dependencies]