summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authoretoledom <etoledom@icloud.com>2019-11-18 17:37:56 +0100
committerAram Drevekenin <aram@poor.dev>2019-11-18 17:37:56 +0100
commit81e95f74f5ac10c60f12b33880d3fe65a1eac549 (patch)
tree831fad07adfbfa25238e2ba0ba5d24aa67e151a0 /Cargo.toml
parentb4b3eace371cf802f261e7b5294365bb9bec63f0 (diff)
refactor(macos): handle lsof in macos in a different module
* Refactor lsof connections as iterator * Fix build issues and warnings * Fix iterator to not finish on first wrong line * Remove println * Fix overflow. Creating the regex instance on every iteration is too bad performant * Adding connection regex as static * Small syntax improvement
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 94ebb0d..f58f3eb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,6 +23,7 @@ signal-hook = "0.1.10"
failure = "0.1.6"
chrono = "0.4"
regex = "1.3.1"
+lazy_static = "1.4.0"
[target.'cfg(target_os="linux")'.dependencies]
procfs = "0.5.3"