summaryrefslogtreecommitdiffstats
path: root/atuin-common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'atuin-common/Cargo.toml')
-rw-r--r--atuin-common/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/atuin-common/Cargo.toml b/atuin-common/Cargo.toml
new file mode 100644
index 00000000..efe7da63
--- /dev/null
+++ b/atuin-common/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "atuin-common"
+version = "0.1.0"
+authors = ["Ellie Huxtable <ellie@elliehuxtable.com>"]
+edition = "2018"
+license = "MIT"
+description = "common library for atuin"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+rust-crypto = "^0.2"
+sodiumoxide = "0.2.6"
+chrono = { version = "0.4", features = ["serde"] }
+eyre = "0.6"
+serde_derive = "1.0.125"
+serde = "1.0.125"
+serde_json = "1.0.64"
+rmp-serde = "0.15.4"
+warp = "0.3"
+uuid = { version = "0.8", features = ["v4"] }