summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml31
1 files changed, 12 insertions, 19 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9a57f947..57cd00e1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,47 +1,40 @@
[package]
name = "atuin"
version = "0.5.0"
-authors = ["Ellie Huxtable <e@elm.sh>"]
+authors = ["Ellie Huxtable <ellie@elliehuxtable.com>"]
edition = "2018"
license = "MIT"
description = "atuin - magical shell history"
+[workspace]
+members = ["./atuin-client", "./atuin-server", "./atuin-common"]
+
[dependencies]
+atuin-server = { path = "atuin-server", version = "0.1.0" }
+atuin-client = { path = "atuin-client", version = "0.1.0" }
+atuin-common = { path = "atuin-common", version = "0.1.0" }
+
log = "0.4"
fern = {version = "0.6.0", features = ["colored"] }
chrono = { version = "0.4", features = ["serde"] }
eyre = "0.6"
-shellexpand = "2"
structopt = "0.3"
directories = "3"
-uuid = { version = "0.8", features = ["v4"] }
indicatif = "0.15.0"
-whoami = "1.1.2"
-chrono-english = "0.1.4"
-cli-table = "0.4"
-config = "0.11"
serde_derive = "1.0.125"
serde = "1.0.125"
serde_json = "1.0.64"
-rmp-serde = "0.15.4"
tui = "0.14"
termion = "1.5"
unicode-width = "0.1"
itertools = "0.10.0"
-dotenv = "0.15.0"
-sodiumoxide = "0.2.6"
-reqwest = { version = "0.11", features = ["blocking", "json"] }
-base64 = "0.13.0"
fork = "0.1.18"
-parse_duration = "2.1.1"
-rand = "0.8.3"
-rust-crypto = "^0.2"
-human-panic = "1.0.3"
tokio = { version = "1", features = ["full"] }
-warp = "0.3"
-sqlx = { version = "0.5", features = [ "runtime-tokio-native-tls", "uuid", "chrono", "postgres" ] }
async-trait = "0.1.49"
-urlencoding = "1.1.1"
+chrono-english = "0.1.4"
+cli-table = "0.4"
+reqwest = { version = "0.11", features = ["blocking", "json"] }
+base64 = "0.13.0"
humantime = "2.1.0"
[dependencies.rusqlite]