summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 9 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bde7ed67..017aa7e2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,11 +1,11 @@
[workspace]
members = [
- "atuin",
- "atuin-client",
- "atuin-server",
- "atuin-server-postgres",
- "atuin-server-database",
- "atuin-common",
+ "atuin",
+ "atuin-client",
+ "atuin-server",
+ "atuin-server-postgres",
+ "atuin-server-database",
+ "atuin-common",
]
[workspace.package]
@@ -35,9 +35,10 @@ semver = "1.0.14"
serde = { version = "1.0.145", features = ["derive"] }
serde_json = "1.0.86"
tokio = { version = "1", features = ["full"] }
-uuid = { version = "1.3", features = ["v4"] }
+uuid = { version = "1.3", features = ["v4", "serde"] }
whoami = "1.1.2"
typed-builder = "0.14.0"
+pretty_assertions = "1.3.0"
[workspace.dependencies.reqwest]
version = "0.11"
@@ -46,4 +47,4 @@ default-features = false
[workspace.dependencies.sqlx]
version = "0.6"
-features = ["runtime-tokio-rustls", "chrono", "postgres"]
+features = ["runtime-tokio-rustls", "chrono", "postgres", "uuid"]