summaryrefslogtreecommitdiffstats
path: root/atuin-common/Cargo.toml
diff options
context:
space:
mode:
authorEllie Huxtable <e@elm.sh>2021-04-20 21:53:07 +0100
committerGitHub <noreply@github.com>2021-04-20 20:53:07 +0000
commita21737e2b7f8d1e426726bdd7536033f299d476a (patch)
treee940afdff9c145d25d9a2895fd44a77d70719a2e /atuin-common/Cargo.toml
parent34888827f8a06de835cbe5833a06914f28cce514 (diff)
Use cargo workspaces (#37)
* Switch to Cargo workspaces Breaking things into "client", "server" and "common" makes managing the codebase much easier! client - anything running on a user's machine for adding history server - handles storing/syncing history and running a HTTP server common - request/response API definitions, common utils, etc * Update dockerfile
Diffstat (limited to 'atuin-common/Cargo.toml')
-rw-r--r--atuin-common/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/atuin-common/Cargo.toml b/atuin-common/Cargo.toml
new file mode 100644
index 00000000..efe7da63
--- /dev/null
+++ b/atuin-common/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "atuin-common"
+version = "0.1.0"
+authors = ["Ellie Huxtable <ellie@elliehuxtable.com>"]
+edition = "2018"
+license = "MIT"
+description = "common library for atuin"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+rust-crypto = "^0.2"
+sodiumoxide = "0.2.6"
+chrono = { version = "0.4", features = ["serde"] }
+eyre = "0.6"
+serde_derive = "1.0.125"
+serde = "1.0.125"
+serde_json = "1.0.64"
+rmp-serde = "0.15.4"
+warp = "0.3"
+uuid = { version = "0.8", features = ["v4"] }