summaryrefslogtreecommitdiffstats
path: root/atuin-client/Cargo.toml
diff options
context:
space:
mode:
author依云 <lilydjwg@gmail.com>2024-03-01 21:21:53 +0800
committerGitHub <noreply@github.com>2024-03-01 13:21:53 +0000
commitaec5df4123823fdaf8db3d714d0d826ac04ceca4 (patch)
treefdac93f22c47cc533a1288eabd97525f64f20716 /atuin-client/Cargo.toml
parent897af9a326960a67fedd68ae85ed8aae0b19db97 (diff)
feat: support regex with r/.../ syntax (#1745)
* feat: support regex with r/.../ syntax * cargo fmt * feat(tests): add some tests for regex matching
Diffstat (limited to 'atuin-client/Cargo.toml')
-rw-r--r--atuin-client/Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/atuin-client/Cargo.toml b/atuin-client/Cargo.toml
index 51227044..e2353daf 100644
--- a/atuin-client/Cargo.toml
+++ b/atuin-client/Cargo.toml
@@ -37,13 +37,12 @@ async-trait = { workspace = true }
itertools = { workspace = true }
rand = { workspace = true }
shellexpand = "3"
-sqlx = { workspace = true, features = ["sqlite"] }
+sqlx = { workspace = true, features = ["sqlite", "regexp"] }
minspan = "0.1.1"
regex = "1.9.1"
serde_regex = "1.1.0"
fs-err = { workspace = true }
sql-builder = "3"
-lazy_static = "1"
memchr = "2.5"
rmp = { version = "0.8.11" }
typed-builder = { workspace = true }