summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorConrad Ludgate <conradludgate@gmail.com>2023-09-11 09:26:05 +0100
committerGitHub <noreply@github.com>2023-09-11 09:26:05 +0100
commitf90c01f702f6a98b041f766b6a1d857bc1b9afef (patch)
tree04a4755bd632abdcf398d0ce903163ed60a5a212 /Cargo.toml
parent2342a3392349c0ae9d742e9da9833590e6567d08 (diff)
replace chrono with time (#806)
* replace chrono with time * Fix test chrono usage --------- Co-authored-by: Ellie Huxtable <ellie@elliehuxtable.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 9 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9b9bfc012..1a8e1d0d5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,7 @@ members = [
name = "atuin"
version = "16.0.0"
authors = ["Ellie Huxtable <ellie@elliehuxtable.com>"]
-rust-version = "1.59"
+rust-version = "1.67"
license = "MIT"
homepage = "https://atuin.sh"
repository = "https://github.com/atuinsh/atuin"
@@ -22,13 +22,13 @@ readme = "README.md"
async-trait = "0.1.58"
base64 = "0.21"
log = "0.4"
-chrono = { version = "0.4", features = ["serde"] }
+time = { version = "0.3", features = ["serde-human-readable", "macros", "local-offset"] }
clap = { version = "4.0.18", features = ["derive"] }
config = { version = "0.13", default-features = false, features = ["toml"] }
directories = "4"
eyre = "0.6"
fs-err = "2.9"
-interim = { version = "0.1.0", features = ["chrono"] }
+interim = { version = "0.1.0", features = ["time"] }
itertools = "0.10.5"
rand = { version = "0.8.5", features = ["std"] }
semver = "1.0.14"
@@ -50,4 +50,9 @@ default-features = false
[workspace.dependencies.sqlx]
version = "0.7.1"
-features = ["runtime-tokio-rustls", "chrono", "postgres", "uuid"]
+features = [
+ "runtime-tokio-rustls",
+ "time",
+ "postgres",
+ "uuid",
+]