summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorEllie Huxtable <e@elm.sh>2021-02-13 17:02:52 +0000
committerEllie Huxtable <e@elm.sh>2021-02-13 17:02:52 +0000
commit7e60ace610ea3d137fac8fd6cfb26a1f5411a609 (patch)
tree493142aa562fa379f82e4f6b2e2a79fa7f9b085b /Cargo.toml
parent50ebe68d9f473a36baf9b7b913230a0e58bd26ca (diff)
Record command exit code and duration
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 9 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bc4d1df2..3172a308 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,14 +7,15 @@ license = "MIT"
description = "atuin - sync your shell history"
[dependencies]
-log = "0.4"
-pretty_env_logger = "0.4"
-chrono = "0.4.19"
-eyre = "0.6.1"
-shellexpand = "2.0.0"
-structopt = "0.3.15"
-directories = "3.0.1"
+log = "0.4.*"
+pretty_env_logger = "0.4.*"
+chrono = "0.4.*"
+eyre = "0.6.*"
+shellexpand = "2.*"
+structopt = "0.3.*"
+directories = "3.*"
+uuid = { version = "0.8", features = ["serde", "v4"] }
[dependencies.rusqlite]
-version = "0.24.0"
+version = "0.24.*"
features = ["bundled"]