summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorEllie Huxtable <e@elm.sh>2021-04-26 14:25:57 +0100
committerGitHub <noreply@github.com>2021-04-26 13:25:57 +0000
commit0610ae197f41c0439665c97d914809bd0b10c2fa (patch)
tree9b2f2f31cb4befbdad26f7801c3fc1ea8c3b6a7f /Cargo.toml
parent646fec893ed611fe9bc1f27fbf18ce292364b3ba (diff)
Pre release polishing (#42)
* Improve readme * Add demo gif * Update readme * Add mac build * Amend release config * Update gif
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 18 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 88a85823..f39702a7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,12 +1,29 @@
[package]
name = "atuin"
-version = "0.6.1"
+version = "0.6.2"
authors = ["Ellie Huxtable <ellie@elliehuxtable.com>"]
edition = "2018"
license = "MIT"
description = "atuin - magical shell history"
homepage = "https://atuin.sh"
repository = "https://github.com/ellie/atuin"
+readme = "README.md"
+
+[package.metadata.deb]
+maintainer = "Ellie Huxtable <ellie@elliehuxtable.com>"
+copyright = "2021, Ellie Huxtable <ellie@elliehuxtable.com>"
+license-file = ["LICENSE"]
+depends = "$auto"
+section = "utility"
+
+[package.metadata.rpm]
+package = "atuin"
+
+[package.metadata.rpm.cargo]
+buildflags = ["--release"]
+
+[package.metadata.rpm.targets]
+atuin = { path = "/usr/bin/atuin" }
[workspace]
members = ["./atuin-client", "./atuin-server", "./atuin-common"]
@@ -39,4 +56,3 @@ base64 = "0.13.0"
humantime = "2.1.0"
tabwriter = "1.2.1"
crossbeam-channel = "0.5.1"
-