summaryrefslogtreecommitdiffstats
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorDavid Hewitt <1939362+davidhewitt@users.noreply.github.com>2020-06-02 22:31:06 +0100
committerGitHub <noreply@github.com>2020-06-02 21:31:06 +0000
commitc102e845cd96dd14fc3ea928eb3c56cf884f8f35 (patch)
treeb65e96339008449f1aa791f97e5691211aaa0053 /alacritty_terminal/Cargo.toml
parent1dacc99183373bffa3ba287aa3241f3b1da67016 (diff)
Add cargo feature for WinPTY
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 99ed6a21..f6f0f365 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -29,7 +29,7 @@ nix = "0.17.0"
signal-hook = { version = "0.1", features = ["mio-support"] }
[target.'cfg(windows)'.dependencies]
-winpty = "0.2.0"
+winpty = { version = "0.2.0", optional = true }
mio-named-pipes = "0.1"
miow = "0.3"
winapi = { version = "0.3.7", features = [
@@ -42,7 +42,7 @@ mio-anonymous-pipes = "0.1"
objc = "0.2.2"
[features]
-default = ["x11", "wayland"]
+default = ["x11", "wayland", "winpty"]
x11 = ["copypasta/x11"]
wayland = ["copypasta/wayland"]
nightly = []