summaryrefslogtreecommitdiffstats
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-08-01 15:37:01 +0000
committerGitHub <noreply@github.com>2019-08-01 15:37:01 +0000
commit9dddf649a15d103295f4ce97b8ae4c178c9623e0 (patch)
tree609cba8c7eecddc8a2b032e826967bcc04395592 /alacritty_terminal/Cargo.toml
parentf51c7b067a05dec7863cca9b8bfaf8329b0cfdfc (diff)
Switch to rfind_url for URL detection
This switches to rfind_url for detecting URLs inside the grid. Instead of expanding at the cursor position, the complete terminal is searched from the bottom until the visible region is left with no active URL. Instead of having the field `cur` publicly accessibly on the `DisplayIterator`, there are the two methods `DisplayIterator::point` and `DisplayIterator::cell` for accessing the current element of the iterator now. This allows accessing the current element right after creating the iterator. Fixes #2629. Fixes #2627.
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 3b9f9918..eb72e7d8 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -32,6 +32,7 @@ terminfo = "0.6.1"
url = "1.7.1"
crossbeam-channel = "0.3.8"
copypasta = { path = "../copypasta" }
+rfind_url = "0.4.0"
[target.'cfg(unix)'.dependencies]
nix = "0.14.1"