summaryrefslogtreecommitdiffstats
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorMateusz MikuĊ‚a <mati865@users.noreply.github.com>2020-09-01 00:30:45 +0200
committerGitHub <noreply@github.com>2020-08-31 22:30:45 +0000
commit5ee7ae8a274fcc58754aa5a91a14b1dedbb87583 (patch)
tree7d122c18517b119d8a4b3b99c337df4b889e5682 /alacritty_terminal/Cargo.toml
parentb39c791649e6d7409ad287741cfef962738c0fd4 (diff)
Disable WinPTY with windows-gnu toolchain
Co-authored-by: Christian Duerr <contact@christianduerr.com>
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 7b11c1e1..7dfa5b09 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -28,7 +28,6 @@ nix = "0.17.0"
signal-hook = { version = "0.1", features = ["mio-support"] }
[target.'cfg(windows)'.dependencies]
-winpty = { version = "0.2.0", optional = true }
mio-named-pipes = "0.1"
miow = "0.3"
winapi = { version = "0.3.7", features = [
@@ -37,6 +36,10 @@ winapi = { version = "0.3.7", features = [
]}
mio-anonymous-pipes = "0.1"
+# Winpty crate supports only MSVC.
+[target.'cfg(all(target_os="windows", target_env="msvc"))'.dependencies]
+winpty = { version = "0.2.0", optional = true }
+
[features]
default = ["winpty"]
bench = []