summaryrefslogtreecommitdiffstats
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorKirill Chibisov <contact@kchibisov.com>2020-03-13 03:33:12 +0300
committerGitHub <noreply@github.com>2020-03-13 03:33:12 +0300
commit4000ec04d89b9bd77995960d2a9da8fcad55e003 (patch)
tree0e38be94eb1d75d70d5dcec7e676c699f3de29a2 /alacritty_terminal/Cargo.toml
parent6d60a49956facc63ab5e0ebac8eb15ab7347ea9a (diff)
Add option to pick Linux/BSD backends
This commit adds two cargo features `x11` and `wayland` to pick Linux/BSD backends, with both enabled by default. Fixes #3340.
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index f86f9456..2fe46d0d 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -24,7 +24,7 @@ unicode-width = "0.1"
base64 = "0.11.0"
terminfo = "0.7.1"
url = "2"
-copypasta = "0.6.1"
+copypasta = { version = "0.6.3", default-features = false }
[target.'cfg(unix)'.dependencies]
nix = "0.16.1"
@@ -44,7 +44,9 @@ mio-anonymous-pipes = "0.1"
objc = "0.2.2"
[features]
-default = []
+default = ["x11", "wayland"]
+x11 = ["copypasta/x11"]
+wayland = ["copypasta/wayland"]
nightly = []
bench = []