summaryrefslogtreecommitdiffstats
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-07-07 14:51:11 +0000
committerGitHub <noreply@github.com>2019-07-07 14:51:11 +0000
commit165246f50aead3a4311df6304830a6e24ef522c8 (patch)
treed4fbec4dfb2a7a51f103aa62aa2c560aceec16be /alacritty_terminal/Cargo.toml
parented7ed473da8ad3147eab32d376a37e391ac7e9db (diff)
Fix saving of ref tests
Since ref tests were only stored whenever winit requested the window close, they would not get stored properly when the terminal was closed through Alacritty using `exit`, Ctrl+D or similar. This moves the ref test code to the and of the main entry point, which will always be executed regardless of how the terminal was shutdown.
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 39228ee3..dd3f1959 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -18,7 +18,6 @@ errno = "0.2"
parking_lot = "0.7"
serde = "1"
serde_derive = "1"
-serde_json = "1"
serde_yaml = "0.8"
vte = "0.3"
mio = "0.6"
@@ -65,3 +64,6 @@ bench = []
[build-dependencies]
gl_generator = "0.11.0"
+
+[dev-dependencies]
+serde_json = "1.0.0"