summaryrefslogtreecommitdiffstats
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <contact@christianduerr.com>2020-01-12 17:28:40 +0100
committerGitHub <noreply@github.com>2020-01-12 17:28:40 +0100
commit12e211d82a1bdef4ffe70c74ee62bc56edfa7590 (patch)
tree4f39080eef31c6bb05d1a77de0b1238e55582f5a /alacritty_terminal/Cargo.toml
parent09ed64bd365bdb294a29e2e6b0149b0581a1fa81 (diff)
Bump VTE to 0.5.0
This change includes dynamic escape buffer support in VTE, which allows us to have arbitrary escape sizes. Since tmux could potentially use very long escapes for the clipboard escape, this allows copying more text. Fixes #1002.
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 7dadca19..abe82512 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -16,7 +16,7 @@ font = { path = "../font" }
parking_lot = "0.9"
serde = { version = "1", features = ["derive"] }
serde_yaml = "0.8"
-vte = "0.3"
+vte = { version = "0.5.0", default-features = false }
mio = "0.6.20"
mio-extras = "2"
log = "0.4"