summaryrefslogtreecommitdiffstats
path: root/alacritty/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <contact@christianduerr.com>2021-10-23 07:16:47 +0000
committerGitHub <noreply@github.com>2021-10-23 07:16:47 +0000
commit1df7dc5171abfe1eab3e95be964f61c5876198f1 (patch)
tree315ceaa093b86b8e875512825302f38e32f697a4 /alacritty/Cargo.toml
parentd8a98f88295e59d6518ae780a9857c033a83161c (diff)
Add multi-window support
Previously Alacritty would always initialize only a single terminal emulator window feeding into the winit event loop, however some platforms like macOS expect all windows to be spawned by the same process and this "daemon-mode" can also come with the advantage of increased memory efficiency. The event loop has been restructured to handle all window-specific events only by the event processing context with the associated window id. This makes it possible to add new terminal windows at any time using the WindowContext::new function call. Some preliminary tests have shown that for empty terminals, this reduces the cost of additional terminal emulators from ~100M to ~6M. However at this point the robustness of the daemon against issues with individual terminals has not been refined, making the reliability of this system questionable. New windows can be created either by using the new `CreateNewWindow` action, or with the `alacritty msg create-window` subcommand. The subcommand sends a message to an IPC socket which Alacritty listens on, its location can be found in the `ALACRITTY_SOCKET` environment variable. Fixes #607.
Diffstat (limited to 'alacritty/Cargo.toml')
-rw-r--r--alacritty/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/alacritty/Cargo.toml b/alacritty/Cargo.toml
index b1fee0c2..5d02d19c 100644
--- a/alacritty/Cargo.toml
+++ b/alacritty/Cargo.toml
@@ -39,7 +39,7 @@ dirs = "3.0.1"
gl_generator = "0.14.0"
[target.'cfg(not(windows))'.dependencies]
-xdg = "2"
+xdg = "2.4.0"
[target.'cfg(not(target_os = "macos"))'.dependencies]
png = { version = "0.16.8", default-features = false, optional = true }