summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-04-19 18:00:24 +0000
committerGitHub <noreply@github.com>2019-04-19 18:00:24 +0000
commitcfc20d4f34dca535654cc32df18e785296af4cc5 (patch)
treeb9697a365d1ec4b3161fd67937497e90a63f5c0d /Cargo.toml
parenta47d716daace7c197392854754406a06454ec380 (diff)
Fix cursor dimensions with font offset
Previously cursor dimensions were not calculated correctly when a font offset was specified, since the font offset was completely ignored. This has been fixed by moving all the cursor logic from the font into the Alacritty crate, applying the config's offsets before rasterizing the cursors. This has also fixed an issue with some cursors not being rendered as double-width correctly when over double-width glyphs. This fixes #2209.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d1ad1bc6..f0206d19 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -41,7 +41,6 @@ log = "0.4"
clap = "2"
fnv = "1"
unicode-width = "0.1"
-arraydeque = "0.4"
glutin = { version = "0.21.0-rc2", features = ["icon_loading"] }
env_logger = "0.6.0"
base64 = "0.10.0"