summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-04-09 19:29:46 +0000
committerGitHub <noreply@github.com>2019-04-09 19:29:46 +0000
commit56fea343ff94b23aa94f8756643c015f20517e8f (patch)
tree3239fc02d89aebdac9d802b66836838102d93e97 /Cargo.toml
parentf2a5def2cbfd4812007aeab16e66c9851bc30d3d (diff)
Set maximum Rust version to 1.31.0
By setting the minimum Rust version and enforcing it with CI, Alacritty should hopefully make it possible for maintainers to package the application even on distributions which are not rolling release. The 1.31.0 target has been chosen here because it's the first version of the Rust 2018 release. Bumping this version in the future should be considered to be a breaking change and should only be done with caution and in consideration of the supported Rust versions of the major distributions available. This fixes #2277.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 26663f6a..d1ad1bc6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,7 +42,7 @@ clap = "2"
fnv = "1"
unicode-width = "0.1"
arraydeque = "0.4"
-glutin = { version = "0.21.0-rc1", features = ["icon_loading"] }
+glutin = { version = "0.21.0-rc2", features = ["icon_loading"] }
env_logger = "0.6.0"
base64 = "0.10.0"
static_assertions = "0.3.0"