summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZac Pullar-Strecker <zacps@users.noreply.github.com>2018-10-17 06:02:52 +1300
committerJoe Wilm <jwilm@users.noreply.github.com>2018-10-16 10:02:52 -0700
commit15e0deae2b49078b47a782679300cdf99d9ce687 (patch)
tree8175fbed0def1af08cd2db41583975adbb27dff1 /Cargo.toml
parentb41c6b736d67d61e92b174dfea58ae46813934cd (diff)
Add support for Windows (#1374)
Initial support for Windows is implemented using the winpty translation layer. Clipboard support for Windows is provided through the `clipboard` crate, and font rasterization is provided by RustType. The tty.rs file has been split into OS-specific files to separate standard pty handling from the winpty implementation. Several binary components are fetched via build script on windows including libclang and winpty. These could be integrated more directly in the future either by building those dependencies as part of the Alacritty build process or by leveraging git lfs to store the artifacts. Fixes #28.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8aedfc33..62d70b4b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -38,12 +38,20 @@ arraydeque = "0.4"
glutin = "0.16"
env_logger = "0.5"
base64 = "0.9.0"
+winit = { version = "0.15", features = ["icon_loading"] }
+image = "0.19"
static_assertions = "0.2.5"
terminfo = "0.6.1"
[target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies]
x11-dl = "2"
+[target.'cfg(windows)'.dependencies]
+winpty = { path = "./winpty" }
+mio-named-pipes = "0.1"
+winapi = { version = "0.3.5", features = ["winuser", "synchapi", "roerrorapi", "winerror"]}
+dunce = "0.1"
+
[target.'cfg(target_os = "macos")'.dependencies]
objc = "0.2.2"
dirs = "1.0.2"
@@ -58,6 +66,12 @@ bench = []
[build-dependencies]
gl_generator = "0.9"
+[target.'cfg(windows)'.build-dependencies]
+embed-resource = "1.1.4"
+reqwest = "0.8"
+tempdir = "0.3"
+zip = "0.4"
+
[profile.release]
lto = true
debug = 1