summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-06-17 21:22:10 +0000
committerGitHub <noreply@github.com>2019-06-17 21:22:10 +0000
commita39459ece2e285f58ce241f8037a1e5fd836877b (patch)
treee91dedf7660efdee8bdc98215bb3cdf985e0c861
parent3950b5cb2f56e2d9daede84f8a9489ac0252508c (diff)
Fix ubuntu deployment
-rw-r--r--INSTALL.md2
-rw-r--r--ci/amd64/Dockerfile (renamed from ci/x86_64/Dockerfile)3
-rwxr-xr-xci/before_deploy.sh101
-rw-r--r--ci/i386/Dockerfile3
4 files changed, 58 insertions, 51 deletions
diff --git a/INSTALL.md b/INSTALL.md
index f470ef10..1e05f599 100644
--- a/INSTALL.md
+++ b/INSTALL.md
@@ -72,7 +72,7 @@ libraries to build Alacritty. Here's an apt command that should install all of
them. If something is still found to be missing, please open an issue.
```sh
-apt-get install cmake pkg-config libfreetype6-dev libfontconfig1-dev libxcb-xfixes0-dev
+apt-get install cmake pkg-config libfreetype6-dev libfontconfig1-dev libxcb-xfixes0-dev python3
```
#### Arch Linux
diff --git a/ci/x86_64/Dockerfile b/ci/amd64/Dockerfile
index b94c07cc..a3cef725 100644
--- a/ci/x86_64/Dockerfile
+++ b/ci/amd64/Dockerfile
@@ -2,7 +2,8 @@ FROM ubuntu:latest
ENV USER root
-RUN apt-get update && apt-get install -y cmake libfreetype6-dev libfontconfig1-dev curl
+RUN apt-get update && apt-get install -y cmake libfreetype6-dev libfontconfig1-dev curl python3 \
+ libxcb-xfixes0-dev
RUN curl https://sh.rustup.rs -sSf | sh -s -- -y
RUN /root/.cargo/bin/cargo install cargo-deb
diff --git a/ci/before_deploy.sh b/ci/before_deploy.sh
index 5919e112..bc834f85 100755
--- a/ci/before_deploy.sh
+++ b/ci/before_deploy.sh
@@ -8,74 +8,79 @@ aux_files=("extra/completions/alacritty.bash"
"extra/alacritty.info"
"alacritty.yml")
-# Get previous tag to check for changes
-git fetch --tags
-git fetch --unshallow
-prev_tag=$(git describe --tags --abbrev=0 $TRAVIS_TAG^)
+# Output binary name
+name="Alacritty-${TRAVIS_TAG}"
# Everything in this directory will be offered as download for the release
mkdir "./target/deploy"
-# Output binary name
-name="Alacritty-${TRAVIS_TAG}"
+function windows {
+ choco install 7zip nuget.commandline
+ nuget install WiX
-if [ "$TRAVIS_OS_NAME" == "osx" ]; then
- rm -rf "./target/release"
- make dmg
- mv "./target/release/osx/Alacritty.dmg" "./target/deploy/${name}.dmg"
-elif [ "$TRAVIS_OS_NAME" == "linux" ] && [ "$ARCH" != "i386" ]; then
- docker pull undeadleech/alacritty-ubuntu
+ # Create zip archive
+ 7z a -tzip "./target/deploy/${name}-windows-portable.zip" "./target/release/alacritty.exe" \
+ "./target/release/winpty-agent.exe"
- # x86_64
- docker run -v "$(pwd):/source" undeadleech/alacritty-ubuntu \
- /root/.cargo/bin/cargo build --release --manifest-path /source/Cargo.toml
- tar -cvzf "./target/deploy/${name}-ubuntu_18_04-x86_64.tar.gz" -C "./target/release/" "alacritty"
+ # Create msi installer
+ ./WiX.*/tools/candle.exe -nologo -arch "x64" -ext WixUIExtension -ext WixUtilExtension -out \
+ "target/alacritty.wixobj" "extra/windows/wix/alacritty.wxs"
+ ./WiX.*/tools/light.exe -nologo -ext WixUIExtension -ext WixUtilExtension -out \
+ "target/installer.msi" -sice:ICE61 -sice:ICE91 "target/alacritty.wixobj"
+ mv "target/installer.msi" "target/deploy/${name}-windows-installer.msi"
+}
- # x86_64 deb
- docker run -v "$(pwd):/source" undeadleech/alacritty-ubuntu \
- sh -c "cd /source && \
- /root/.cargo/bin/cargo deb --no-build --manifest-path alacritty/Cargo.toml --output ./target/deploy/${name}-ubuntu_18_04_amd64.deb"
+function osx {
+ rm -rf "./target/release" \
+ && make dmg \
+ && mv "./target/release/osx/Alacritty.dmg" "./target/deploy/${name}.dmg"
+}
- # Make sure all files can be uploaded without permission errors
- sudo chown -R $USER:$USER "./target"
-elif [ "$TRAVIS_OS_NAME" == "linux" ] && [ "$ARCH" == "i386" ]; then
- docker pull undeadleech/alacritty-ubuntu-i386
+function debian {
+ arch=$1
- # i386
- docker run -v "$(pwd):/source" undeadleech/alacritty-ubuntu-i386 \
+ docker pull "undeadleech/alacritty-ubuntu-${arch}" \
+ && docker_tar "alacritty-ubuntu-${arch}" "ubuntu_18_04_${arch}" \
+ && docker_deb "alacritty-ubuntu-${arch}" "ubuntu_18_04_${arch}" \
+ && sudo chown -R $USER:$USER "./target"
+}
+
+function docker_tar {
+ image=$1
+ archname=$2
+
+ docker run -v "$(pwd):/source" "undeadleech/${image}" \
/root/.cargo/bin/cargo build --release --manifest-path /source/Cargo.toml
- tar -cvzf "./target/deploy/${name}-ubuntu_18_04-i386.tar.gz" -C "./target/release/" "alacritty"
- # i386 deb
- docker run -v "$(pwd):/source" undeadleech/alacritty-ubuntu-i386 \
- sh -c "cd /source && \
- /root/.cargo/bin/cargo deb --no-build --manifest-path alacritty/Cargo.toml --output ./target/deploy/${name}-ubuntu_18_04_i386.deb"
+ tar -cvzf "./target/deploy/${name}-${archname}.tar.gz" -C "./target/release/" "alacritty"
+}
- # Make sure all files can be uploaded without permission errors
- sudo chown -R $USER:$USER "./target"
-elif [ "$TRAVIS_OS_NAME" == "windows" ]; then
- choco install 7zip nuget.commandline
- nuget install WiX
+function docker_deb {
+ image=$1
+ archname=$2
- # Create zip archive
- 7z a -tzip "./target/deploy/${name}-windows-portable.zip" "./target/release/alacritty.exe" \
- "./target/release/winpty-agent.exe"
+ docker run -v "$(pwd):/source" "undeadleech/${image}" sh -c \
+ "cd /source && /root/.cargo/bin/cargo deb --no-build --manifest-path alacritty/Cargo.toml \
+ --output ./target/deploy/${name}-${archname}.deb"
+}
- # Create msi installer
- ./WiX.*/tools/candle.exe -nologo -arch "x64" -ext WixUIExtension -ext WixUtilExtension -out "target/alacritty.wixobj" "extra/windows/wix/alacritty.wxs"
- ./WiX.*/tools/light.exe -nologo -ext WixUIExtension -ext WixUtilExtension -out "target/installer.msi" -sice:ICE61 -sice:ICE91 "target/alacritty.wixobj"
- mv "target/installer.msi" "target/deploy/${name}-windows-installer.msi"
+if [ "$TRAVIS_OS_NAME" == "osx" ]; then
+ osx || exit
+elif [ "$TRAVIS_OS_NAME" == "linux" ] && [ "$ARCH" != "i386" ]; then
+ debian "amd64" || exit
+elif [ "$TRAVIS_OS_NAME" == "linux" ] && [ "$ARCH" == "i386" ]; then
+ debian "i386" || exit
+elif [ "$TRAVIS_OS_NAME" == "windows" ]; then
+ windows
fi
# Convert and add manpage if it changed
-if [ -n "$(git diff $prev_tag HEAD extra/alacritty.man)" ]; then
- gzip -c "./extra/alacritty.man" > "./target/deploy/alacritty.1.gz"
-fi
+gzip -c "./extra/alacritty.man" > "./target/deploy/alacritty.1.gz" || exit
# Rename Alacritty logo to match .desktop file
-cp "./extra/logo/alacritty-term.svg" "./target/deploy/Alacritty.svg"
+cp "./extra/logo/alacritty-term.svg" "./target/deploy/Alacritty.svg" || exit
# Offer various other files
for file in "${aux_files[@]}"; do
- cp $file "./target/deploy/"
+ cp $file "./target/deploy/" || exit
done
diff --git a/ci/i386/Dockerfile b/ci/i386/Dockerfile
index cdec1ec5..6c53d14b 100644
--- a/ci/i386/Dockerfile
+++ b/ci/i386/Dockerfile
@@ -2,7 +2,8 @@ FROM i386/ubuntu:latest
ENV USER root
-RUN apt-get update && apt-get install -y cmake libfreetype6-dev libfontconfig1-dev curl
+RUN apt-get update && apt-get install -y cmake libfreetype6-dev libfontconfig1-dev curl python3 \
+ libxcb-xfixes0-dev
RUN curl https://sh.rustup.rs -sSf | sh -s -- -y
RUN /root/.cargo/bin/rustup default stable-i686-unknown-linux-gnu