summaryrefslogtreecommitdiffstats
path: root/openbb_platform/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openbb_platform/pyproject.toml')
-rw-r--r--openbb_platform/pyproject.toml82
1 files changed, 41 insertions, 41 deletions
diff --git a/openbb_platform/pyproject.toml b/openbb_platform/pyproject.toml
index 8c8b4a4005c..00a3782a458 100644
--- a/openbb_platform/pyproject.toml
+++ b/openbb_platform/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "openbb"
-version = "4.2.2"
+version = "4.2.3"
description = "Investment research for everyone, anywhere."
authors = ["OpenBB Team <hello@openbb.co>"]
license = "AGPL-3.0-only"
@@ -9,52 +9,52 @@ packages = [{ include = "openbb" }]
[tool.poetry.dependencies]
python = ">=3.8,<3.12"
-openbb-core = "^1.2.4"
+openbb-core = "^1.2.5"
-openbb-benzinga = "^1.2.2"
-openbb-econdb = "^1.1.2"
-openbb-federal-reserve = "^1.2.2"
-openbb-fmp = "^1.2.2"
-openbb-fred = "^1.2.2"
-openbb-intrinio = "^1.2.2"
-openbb-oecd = "^1.2.2"
-openbb-polygon = "^1.2.2"
-openbb-sec = "^1.2.2"
-openbb-tiingo = "^1.2.2"
-openbb-tradingeconomics = "^1.2.2"
-openbb-yfinance = "^1.2.2"
+openbb-benzinga = "^1.2.3"
+openbb-econdb = "^1.1.3"
+openbb-federal-reserve = "^1.2.3"
+openbb-fmp = "^1.2.3"
+openbb-fred = "^1.2.3"
+openbb-intrinio = "^1.2.3"
+openbb-oecd = "^1.2.3"
+openbb-polygon = "^1.2.3"
+openbb-sec = "^1.2.3"
+openbb-tiingo = "^1.2.3"
+openbb-tradingeconomics = "^1.2.3"
+openbb-yfinance = "^1.2.3"
-openbb-commodity = "^1.1.2"
-openbb-crypto = "^1.2.2"
-openbb-currency = "^1.2.2"
-openbb-derivatives = "^1.2.2"
-openbb-economy = "^1.2.2"
-openbb-equity = "^1.2.2"
-openbb-etf = "^1.2.2"
-openbb-fixedincome = "^1.2.2"
-openbb-index = "^1.2.2"
-openbb-news = "^1.2.2"
-openbb-regulators = "^1.2.2"
+openbb-commodity = "^1.1.3"
+openbb-crypto = "^1.2.3"
+openbb-currency = "^1.2.3"
+openbb-derivatives = "^1.2.3"
+openbb-economy = "^1.2.3"
+openbb-equity = "^1.2.3"
+openbb-etf = "^1.2.3"
+openbb-fixedincome = "^1.2.3"
+openbb-index = "^1.2.3"
+openbb-news = "^1.2.3"
+openbb-regulators = "^1.2.3"
# Community dependencies
-openbb-alpha-vantage = { version = "^1.2.2", optional = true }
-openbb-biztoc = { version = "^1.2.2", optional = true }
-openbb-cboe = { version = "^1.2.2", optional = true }
-openbb-ecb = { version = "^1.2.2", optional = true }
-openbb-finra = { version = "^1.2.2", optional = true }
-openbb-finviz = { version = "^1.1.2", optional = true }
-openbb-government-us = { version = "^1.2.2", optional = true }
-openbb-nasdaq = { version = "^1.2.2", optional = true }
-openbb-seeking-alpha = { version = "^1.2.2", optional = true }
-openbb-stockgrid = { version = "^1.2.2", optional = true }
-openbb-tmx = { version = "^1.1.2", optional = true }
-openbb-tradier = { version = "^1.1.2", optional = true }
-openbb-wsj = { version = "^1.2.2", optional = true }
+openbb-alpha-vantage = { version = "^1.2.3", optional = true }
+openbb-biztoc = { version = "^1.2.3", optional = true }
+openbb-cboe = { version = "^1.2.3", optional = true }
+openbb-ecb = { version = "^1.2.3", optional = true }
+openbb-finra = { version = "^1.2.3", optional = true }
+openbb-finviz = { version = "^1.1.3", optional = true }
+openbb-government-us = { version = "^1.2.3", optional = true }
+openbb-nasdaq = { version = "^1.2.3", optional = true }
+openbb-seeking-alpha = { version = "^1.2.3", optional = true }
+openbb-stockgrid = { version = "^1.2.3", optional = true }
+openbb-tmx = { version = "^1.1.3", optional = true }
+openbb-tradier = { version = "^1.1.3", optional = true }
+openbb-wsj = { version = "^1.2.3", optional = true }
openbb-charting = { version = "^2.1.2", optional = true }
-openbb-econometrics = { version = "^1.2.2", optional = true }
-openbb-quantitative = { version = "^1.2.2", optional = true }
-openbb-technical = { version = "^1.2.2", optional = true }
+openbb-econometrics = { version = "^1.2.3", optional = true }
+openbb-quantitative = { version = "^1.2.3", optional = true }
+openbb-technical = { version = "^1.2.3", optional = true }
[tool.poetry.extras]
alpha_vantage = ["openbb-alpha-vantage"]