summaryrefslogtreecommitdiffstats
path: root/jupyterlab/gst/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'jupyterlab/gst/pyproject.toml')
-rw-r--r--jupyterlab/gst/pyproject.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/jupyterlab/gst/pyproject.toml b/jupyterlab/gst/pyproject.toml
new file mode 100644
index 00000000000..954217304be
--- /dev/null
+++ b/jupyterlab/gst/pyproject.toml
@@ -0,0 +1,17 @@
+[build-system]
+requires = ["jupyter_packaging~=0.10,<2", "jupyterlab~=3.1"]
+build-backend = "jupyter_packaging.build_api"
+
+[tool.jupyter-packaging.options]
+skip-if-exists = ["gamestonk_terminal_launcher/labextension/static/style.js"]
+ensured-targets = ["gamestonk_terminal_launcher/labextension/static/style.js", "gamestonk_terminal_launcher/labextension/package.json"]
+
+[tool.jupyter-packaging.builder]
+factory = "jupyter_packaging.npm_builder"
+
+[tool.jupyter-packaging.build-args]
+build_cmd = "build:prod"
+npm = ["jlpm"]
+
+[tool.check-manifest]
+ignore = ["gamestonk_terminal_launcher/labextension/**", "yarn.lock", ".*", "package-lock.json"]