summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index a74c1311..dc5547de 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -90,6 +90,7 @@ rand_core = { version = "0.6", optional = true }
ripemd = { version = "0.1", features = ["oid"], optional = true }
rsa = { version = "0.9.0", optional = true }
sha2 = { version = "0.10", features = ["oid"], optional = true }
+sha3 = { version = "0.10", features = ["oid"], optional = true }
twofish = { version = "0.7", optional = true, features = ["zeroize"] }
typenum = { version = "1.12.0", optional = true }
x25519-dalek = { version = "2", optional = true, default-features = false, features = ["static_secrets", "zeroize"] }
@@ -120,6 +121,7 @@ crypto-rust = [
"dep:cast5", "dep:cfb-mode", "dep:cipher", "dep:des", "dep:digest",
"dep:eax", "dep:ecb", "dep:ed25519", "dep:ed25519-dalek", "dep:idea",
"dep:md-5", "dep:num-bigint-dig", "dep:ripemd", "dep:rsa", "dep:sha2",
+ "dep:sha3",
"sha1collisiondetection/digest-trait", "sha1collisiondetection/oid",
"dep:twofish", "dep:typenum", "dep:x25519-dalek", "dep:p256",
"dep:rand", "rand?/getrandom", "dep:rand_core", "rand_core?/getrandom",