summaryrefslogtreecommitdiffstats
path: root/qtpass.spec
diff options
context:
space:
mode:
authorBram Vandoren <brouwer@annejan.com>2015-12-01 14:55:48 +0100
committerBram Vandoren <bram.vandoren@ster.kuleuven.be>2015-12-01 14:55:48 +0100
commit74eea5eb2dcd37e1aed9d777e85ceb4f51f562cb (patch)
tree2904b9ed25a03016ea8b5c22ecfbcc4245f16eff /qtpass.spec
parent739c73a4cec94a13dd5ed712cbade4c5b0cd977d (diff)
initial attempt to create a RPM spec file
Diffstat (limited to 'qtpass.spec')
-rw-r--r--qtpass.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/qtpass.spec b/qtpass.spec
new file mode 100644
index 00000000..ea69c108
--- /dev/null
+++ b/qtpass.spec
@@ -0,0 +1,47 @@
+# This is an initial attempt to create a RPM spec file for qtpass. Tested on Fedora 23.
+# Replace the Version number with the current version number (at the time of writing 1.0.5.1)
+# Check qtpass.pro for the current version.
+# After that
+# tar cvfz qtpass-1.0.5.1.tar.gz qtpass-1.0.5.1
+# rpmbuild -tb qtpass-1.0.5.1.tar.gz
+# This should probably be part of a release process.
+
+Name: qtpass
+Version: 1.0.5.1
+Release: 1%{?dist}
+Summary: QtPass is a multi-platform GUI for pass, the standard unix password manager.
+License: GPLv3
+URL: https://qtpass.org/
+Source0: %{name}-%{version}.tar.gz
+
+BuildRequires: qt5-qtbase-devel
+Requires: pass
+Requires: qt5-qtbase
+
+%description
+QtPass is a GUI for pass, the standard unix password manager.
+Features:
+ - Using pass or git and gpg2 directly
+ - Configurable shoulder surfing protection options
+ - Cross platform: Linux, BSD, OS X and Windows
+ - Per-folder user selection for multi recipient encryption
+ - Multiple profiles
+
+%prep
+%setup -q
+
+%build
+qmake-qt5 PREFIX=%{buildroot}/%{_bindir}
+make %{?_smp_mflags}
+
+%install
+%make_install
+
+%files
+%doc
+%{_bindir}/*
+
+%changelog
+* Tue Dec 01 2015 serstring=Bram Vandoren <bram.vandoren@ster.kuleuven.be> - 1.0.5-1
+- Initial RPM spec
+