summaryrefslogtreecommitdiffstats
path: root/bin/domain/imag-todo/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2019-12-01 12:54:11 +0100
committerMatthias Beyer <mail@beyermatthias.de>2019-12-01 12:54:11 +0100
commitcadd9f894478b4c5a9c173655e506c5f4794e04a (patch)
tree5844cb3559cd664ef4ef7b8e3153b031f10efcf9 /bin/domain/imag-todo/Cargo.toml
parentc2d4ec5fefe5de8871d974e7dd61af0fa618ae91 (diff)
Rewrite show functionality of imag-todo
This implementation uses the handlebars crate so that the show format can be specified in the configuration file. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'bin/domain/imag-todo/Cargo.toml')
-rw-r--r--bin/domain/imag-todo/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/bin/domain/imag-todo/Cargo.toml b/bin/domain/imag-todo/Cargo.toml
index bbb5667a..3cb37b5a 100644
--- a/bin/domain/imag-todo/Cargo.toml
+++ b/bin/domain/imag-todo/Cargo.toml
@@ -29,6 +29,7 @@ chrono = "0.4"
filters = "0.3"
kairos = "0.3"
resiter = "0.4.0"
+handlebars = "2"
libimagrt = { version = "0.10.0", path = "../../../lib/core/libimagrt" }
libimagstore = { version = "0.10.0", path = "../../../lib/core/libimagstore" }
@@ -37,6 +38,7 @@ libimagentryedit = { version = "0.10.0", path = "../../../lib/entry/libimagentry
libimagtodo = { version = "0.10.0", path = "../../../lib/domain/libimagtodo" }
libimagutil = { version = "0.10.0", path = "../../../lib/etc/libimagutil" }
libimagentryview = { version = "0.10.0", path = "../../../lib/entry/libimagentryview" }
+libimaginteraction = { version = "0.10.0", path = "../../../lib/etc/libimaginteraction" }
[dependencies.clap]
version = "2.33.0"