summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2024-04-28 15:27:33 -0400
committerGitHub <noreply@github.com>2024-04-28 15:27:33 -0400
commit6591b750f6461c1b141dda6c504ca32f382a422f (patch)
tree01ac18b2c1c161a27081a9959838fb879f67b458 /Cargo.toml
parentf23233e82467fec4ba222700cb08827b11da071a (diff)
deps: bump deps as of 2024-04-28 (#1450)
* deps: bump deps as of 2024-04-28 * fix tests * extra test
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b89c4ad7..0e24e82f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -90,28 +90,28 @@ kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.21", optional = true }
nvml-wrapper = { version = "0.10.0", optional = true, features = ["legacy-functions"] }
regex = "1.10.4"
-serde = { version = "1.0.197", features = ["derive"] }
+serde = { version = "1.0.199", features = ["derive"] }
starship-battery = { version = "0.8.3", optional = true }
-sysinfo = "=0.30.10"
-thiserror = "1.0.58"
+sysinfo = "=0.30.11"
+thiserror = "1.0.59"
time = { version = "0.3.36", features = ["formatting", "macros"] }
-toml_edit = { version = "0.22.9", features = ["serde"] }
-tui = { version = "0.26.1", package = "ratatui" }
+toml_edit = { version = "0.22.12", features = ["serde"] }
+tui = { version = "0.26.2", package = "ratatui" }
unicode-segmentation = "1.11.0"
-unicode-width = "0.1.11"
+unicode-width = "0.1.12"
[target.'cfg(unix)'.dependencies]
libc = "0.2.153"
[target.'cfg(target_os = "linux")'.dependencies]
-rustix = { version = "0.38.32", features = ["fs", "param", "process"] }
+rustix = { version = "0.38.34", features = ["fs", "param", "process"] }
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.9.4"
mach2 = "0.4.2"
[target.'cfg(target_os = "windows")'.dependencies]
-windows = { version = "0.54.0", features = [
+windows = { version = "0.56.0", features = [
"Win32_Foundation",
"Win32_Security",
"Win32_Storage_FileSystem",
@@ -122,7 +122,7 @@ windows = { version = "0.54.0", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.115" }
+serde_json = { version = "1.0.116" }
sysctl = { version = "0.5.5" }
filedescriptor = "0.8.2"