summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-09-12 03:36:45 -0400
committerGitHub <noreply@github.com>2023-09-12 03:36:45 -0400
commit5d455354dd413b14d5e3521b10bb8bcb3664ff8f (patch)
treebe537f33bdbebafa8bb8843955deadc7c118d6ef /Cargo.toml
parent6256742f816132cc439beff14ad2db9dad016d24 (diff)
bump clap and add nushell/fig completions (#1300)
* add nushell and fig completion generation * now bump clap * bump cargo-action too * add rust-version key and set to 1.70.0, N-2
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 7 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2dd637ce..f623fbe9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,6 +31,7 @@ exclude = [
"Cross.toml",
"rustfmt.toml",
]
+rust-version = "1.70.0"
[[bin]]
name = "btm"
@@ -79,7 +80,7 @@ default = ["deploy"]
anyhow = "1.0.75"
backtrace = "0.3.69"
cfg-if = "1.0.0"
-clap = { version = "4.3.23", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.4.2", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.27.0"
ctrlc = { version = "3.4.0", features = ["termination"] }
@@ -139,9 +140,11 @@ cargo-husky = { version = "1.5.0", default-features = false, features = [
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.3.23", features = ["default", "cargo", "wrap_help"] }
-clap_complete = "4.3.2"
-clap_mangen = "0.2.12"
+clap = { version = "4.4.2", features = ["default", "cargo", "wrap_help"] }
+clap_complete = "4.4.1"
+clap_complete_fig = "4.4.0"
+clap_complete_nushell = "4.4.0"
+clap_mangen = "0.2.13"
[package.metadata.deb]
section = "utility"